[En] Zyan doesn't work on asp.net (solved)

Topics: Technical Support
Nov 7, 2013 at 2:19 AM
I use zyan client class to asp.net project, but it not work well, it thow a exception
like follow picture
Image
Coordinator
Nov 7, 2013 at 7:15 AM
Hi,

can you zip & upload your project somewhere so I can reproduce the issue?
Coordinator
Nov 13, 2013 at 1:13 PM
Hi,

any news on this?
Have you received my reply?
My email is yallie at yandex.ru
Nov 13, 2013 at 1:36 PM
Edited Nov 13, 2013 at 1:50 PM
In debugging, will be the exception

click here to download demo
Coordinator
Nov 13, 2013 at 9:21 PM
Edited Nov 13, 2013 at 9:34 PM
Hi quitewing!
Thanks a lot for submitting the project.

It appears to be a known problem of Visual Studio Development WebServer. Here are a few related links:
To work around this issue, please use another web server for debugging the web application.
Visual Studio out of the box can use IIS or IIS Express to debug ASP.NET projects.
To enable it, open ZyanDemo.Web project properties, go to "Web" tab on the left-hand side, scroll down to the "Servers" section and check both "Use local IIS Web Server" and "Use IIS Express" boxes as shown below:

Visual Studio Project Settings

To run the application, start up the console server host, select ZyanDemo.Web as startup project in your solution and hit F5. Here is what you'll get in a web browser:

ZyanDemo.Web running in Google Chrome

You can also use full IIS (not IIS Express) but this way you'll need to run Visual Studio as Administrator.
Coordinator
Nov 13, 2013 at 10:12 PM
Edited Nov 13, 2013 at 10:13 PM
Also, as an even simpler workaround, you can try installing Zyan.Communication.dll into GAC:
gacutil.exe /i Zyan.Communication.dll
Gacutil should be run as an Administrator. It's located here: "C:\Program Files (x86)\Microsoft SDKs\Windows\v8.0A\bin\NETFX 4.0 Tools\gacutil.exe"

Please let me know if it helps.
Marked as answer by yallie on 11/13/2013 at 9:19 PM
Nov 14, 2013 at 1:06 AM

Thanks for your reply, I know what to do.



------------------ 原始邮件 ------------------
发件人: "yallie";<[email removed]>;
发送时间: 2013年11月14日(星期四) 凌晨5:21
收件人: "quietwing.y"<[email removed]>;
主题: Re: [En]Zyan not work on asp.net [zyan:466723]

From: yallie

Hi quitewing!
Thanks a lot for submitting the project.

It appears to be a known problem of Visual Studio Development WebServer (CASSINI). Links:
To work around it, please use another web-server for debugging the web application.
Visual Studio out of the box can use IIS or IIS Express to debug ASP.NET projects.
To enable it, run Visual Studio as Administrator, open ZyanDemo.Web project properties, go to "Web" tab on the left-hand side, scroll down to the "Servers" section and check "Use local IIS Web Server" and "Use IIS Express" boxes as shown below:



To run the application, start up the console server host, select ZyanDemo.Web as startup project in your solution and hit F5. Here is what you'll get in a web browser:


Nov 14, 2013 at 1:30 AM
Edited Nov 14, 2013 at 1:30 AM
yallie wrote:
Also, as an even simpler workaround, you can try installing Zyan.Communication.dll into GAC:
gacutil.exe /i Zyan.Communication.dll
Gacutil should be run as an Administrator. It's located here: "C:\Program Files (x86)\Microsoft SDKs\Windows\v8.0A\bin\NETFX 4.0 Tools\gacutil.exe"

Please let me know if it helps.
Yes, debugging success, thanks for your help